[AlternC-dev] Bug dans l'install

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

Benjamin Sonntag benjamin at octopuce.com
Mar 19 Oct 12:04:49 CEST 2004


larpoux wrote:

>
> Folks,
>
> Je suis tombé sur un bug dans l'installation d'alternc:
> Sur ma toute nouvelle knoppix, il faut utiliser php4-cgi au lieu de php4
> tout court pour pouvoir appeler les fonctions "mysql-connect"  et
> "mysql-pconnect"
>
> fatal Error : undefined function : mysql-pconnect()
> usr/share/alternc/install/newone.php
>
> Je suppose qu'il faut ruser pour appeler php4 sur certaines versions de
> Debian et php4-cgi sur d'autres (dont la mienne).

En fait /usr/bin/php4 marche sur toutes les version de php4 de Debian, 
c'est du paquet en dépendance dont il s'agit. Sur woody on a php4-cgi, 
et sarge c'est php4. J'ai aussi vu (je ne sais plus où) php4-cli.
Bref, il faudrait modifier dans le fichier control la liste des 
dépendances pour remplacer
php4
par
php4 | php4-cgi

Sinon, le problème de mysql_connect vient du fait que le module 
php4-mysql n'est pas chargé dans /etc/php4/cgi/php.ini

> Question annexe :
> je ne sais pas si c'est le bon endroit pour remonter une anomalie dans
> AlternC ou s'il faut rentrer la chose dans la base de bugs moi-même...

Tu peux (et nous t'encourageons à ...) déposer ton bug sur 
http://mantis.alternc.org/

@+

Benjamin



Plus d'informations sur la liste de diffusion Dev