[AlternC-dev] MAJ pre-1.0

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

denis denis at collectifs.net
Ven 29 Avr 21:55:32 CEST 2005


Le vendredi 29 avril 2005 à 15:38 -0400, The Anarcat a écrit :
> > 
> > 1er problème: définir par défaut alternc comme user et comme base de
> > données. ça fait complètement planter l'install. Il faut aller remettre
> > le user et le nom de la table dans alternc.conf et relancer l'install et
> > là ça passe ...
>  
> encore une fois: les scripts de config d'alternc lisent
> /etc/alternc/local.sh et y prennent les valeurs username/pass
> nécessaires... 
> 
> alternc comme valeur par défaut, ça s'applique seulement aux nouveaux
> installs. les upgrades vont prendre les valeurs déjà existantes.

Pour les deux points, dans mon cas, les scripts ne fonctionnent pas donc
il doit bien y avoir un problème ...


> 
> > Comme le script récupère des données comme le mot de passe, il pourrait
> > aussi récupérer ces deux données...
> 
> il le fait. Du moins, les packages buildés du CVS le font. Il y a des
> bugs dans la 0.9.3 qui empêchent ceci, et que j'ai réglé.

J'ai généré un paquet avec les sources du jour.

> 
> > 2ème problème et là c'est un peu plus chiant:
> > 
> > Ldap ne fonctionne plus: 
> > > Starting OpenLDAP: slapd - failed:
> > > /etc/ldap/core.schema: line 33: attribute type "2.5.18.1" is operational
> 
> Cette erreur ressemble au problème que j'ai vu en upgradant sarge
> *avant* l'upgrade alternc -> 0.9.3.

J'ai fait tout en même temps vu qu'alternc n'est plus dispo sous
woody...

C'est peut-être là l'erreur ...

>  Est-ce que tu es sûr d'avoir pris le
> package pour woody si tu es sur Woody?

...

>  Si tu es sur sarge, alors
> galère... je ne sais pas si ldap est bien supporté sur sarge... jamais
> essayé.
>  

Si, la conf alternc a pas suivi donc ça ne marche plus...

Peut-être faire un downgrade de ldap ...

> 
> on dirait que tu n'as pas suivi la procédure documentée dans la page
> UpgradeAlternc que j'ai écrite... 

Si si


> Le parse error ci-haut ne devrait plus
> exister dans le CVS.
> 
> Il nous manque des infos:
> 
>  * sarge ou woody?

MAJ de woody vers sarge.

>  * d'où as-tu pris le package? CVS?

CVS du jour (16h00)

> 
> En espérant que ça aide un peu...

Ben, de ce que je comprends il aurait d'abord fallu mettre à jour
alternc sous woody (mais apparement c'est plus possible), lancer
l'upgrade puis mettre à jour en sarge ?

...

A+
Denis






Plus d'informations sur la liste de diffusion Dev