[AlternC-dev] se débarrasser de php4

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

jonathan jonathan at globenet.org
Lun 13 Fév 18:49:11 CET 2006


Fil a écrit :
> Coucou,
> 
> comment fait-on pour ne plus avoir besoin du tout de php4 ?  On essaie de
> passer en tout-php5 mais il reste une dépendance sur php4-cli (d'après ce
> que me dit Kilian).

Ce sont les fichiers de contrôle de dépendance des paquets qui ne 
permettent pas l'alternative (sans aucun doute exclusivement parce 
qu'ils ont été écrits à une époque où les paquets debian officiels 
n'existaient pas, normalement ça ne fait pas de choses bizarres et ça 
devrait tourner pareil). Les paquets d'alternc qui veulent absolument un 
php numéro quatre sont :

alternc-cacti (php4-cli)
alternc-awstats (php4-cgi)
alternc-phpcron (php4-cgi)
alternc-stats (php4-cli)
alternc-webalyser (php4-cli)

Il faudrait aussi vérifier qu'il n'y a pas des appels explicites à un 
binaire nommé php4 dans les scripts.

O+

-- 
Jonathan



Plus d'informations sur la liste de diffusion Dev