RE: [AlternC-dev] apache 1.3 etch, probleme alias qui ne marchait pas : Résolu

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

Olivier Huet (Perso) olivier.huet31 at free.fr
Mer 4 Avr 17:52:17 CEST 2007


> -----Message d'origine-----
> De : dev-bounces at alternc.org [mailto:dev-bounces at alternc.org] De la part
> de Benjamin Sonntag
> Envoyé : mercredi 4 avril 2007 16:16
> À : Liste de Développement de nouvelles fonctionnalités pour AlternC
> Objet : Re: [AlternC-dev] apache 1.3 etch, probleme alias qui ne marchait
> pas : Résolu
> 
> Si vous avez un problème de gestion des alias avec Apache 1.3 Etch et
> AlternC, voici comment procéder :
> 
> dans /etc/apache/conf.d/alternc.conf, j'ai viré
> LoadModule vhost_alias_module /usr/lib/apache/1.3/mod_vhost_alias.so
> 
> et je l'ai remis dans /etc/apache/modules.conf ici, juste avant
> alias_module :
> LoadModule vhost_alias_module /usr/lib/apache/1.3/mod_vhost_alias.so
> LoadModule alias_module /usr/lib/apache/1.3/mod_alias.so
> 
> reload d'apache
> > alias pris en compte chez moi.

Ca alors...
Je viens moi aussi de régler le pb d'une façon presque identique :
 - mise en commentaire de la ligne LoadModule dans alternc.conf
 - apache-modconf apache enable mod_vhost_alias
 - apachectl graceful

Il semble que apache-modconf place le LoadModule au bon endroit :)
(cad quasiment au tout début de modules.conf)
Je suspecte que si ce module est chargé après alias, c'est alias qui prend
le pas et qu'il ne sache pas gérer les vhosts.
(ce qui ne semblait pas être le cas avant)

Je suggère d'intégrer cette modif au SVN :
  - virer la ligne LoadModule, 
  - rajouter un "apache-modconf apache enable mod_vhost_alias" suivi d'un
"apache-modconf apache-ssl enable mod_vhost_alias" dans le script d'install

Merci en tout cas Benjamin de t'être penché sur ce problème :)
(et j'aurais du lire mes mails plus tôt ;) )





Plus d'informations sur la liste de diffusion Dev