[AlternC-Users] Acces refuse (pb de cookie)

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

Olivier HUET o.huet at apogea.net
Mar 10 Fév 18:37:17 CET 2004


De toute evidence ton fichier php.ini n'est pas lu...

1) Verifie que tu as bien mis le php.ini au bon endroit
(cad normalement /etc/php4/apache)

2) Verifie que php.ini est bien accessible a apache avec un "ls -l /etc/php4/apache"
(normalement tout le monde doit pouvoir le lire et seul le root, son proprietaire, a acces en ecriture)

3) Verifie que tu n'as pas un autre php.ini ailleurs que php chargerait en priorite.
Un "find / -iname php.ini" me donne sur ma machine :
/etc/php4/apache/php.ini
/etc/php4/cgi/php.ini
/usr/share/alternc/1.0/cvs/alternc/install/scripts/etc/php4/apache/php.ini
/usr/share/alternc/1.0/cvs/alternc/install/scripts/etc/php4/cgi/php.ini
/usr/share/alternc/1.0/install/etc/php4/apache/php.ini
/usr/share/alternc/1.0/install/etc/php4/cgi/php.ini
/usr/share/doc/php4-cgi/examples/php.ini
/usr/share/doc/php4/examples/php.ini

4) Peut etre que "/etc/init.d/apache restart" n'a pas correctement termine le service httpd ?
Peut etre qu'un reboot complet de la machine serait plus efficace.

-----Message d'origine-----
De:	Christian Pollet-Thiollier [SMTP:christian.pollet at logidis.com]
Date:	mardi 10 fevrier 2004 18:23
A:	Liste des utilisateurs heberges d'Alt ernC.
Objet:	Re: [AlternC-Users]  Acces refuse (pb  de cookie)

Bonjour,

Olivier HUET wrote:

 > Juste comme ca, l'adresse est incorrete.
 >
 > La bonne adresse est :
 > 
http://dev.alternc.org/cgi-bin/viewcvs.cgi/*checkout*/alternc/install/scripts/etc/php4/apache/php.ini?rev=1.2
 >
 > (note le *checkout* et le .ini au lieu de .ii)
 >

Ooops,

Enfin, maintenant j'ai un php.ini de premiere main, et mon probleme est 
toujours le meme.

En creusant, j'ai decouvert que la variable global $session est a "" au 
moment du checkid, comme d'ailleurs les autres variables globales 
$username et $password.
Pas etonnant que le login echoue.

J'ai essaye de suivre le deroulement du script, et je n'ai pas trouve de 
fonction de mapping des variables POST, donc on doit compter sur un 
register_globals ON, ce que demande d'ailleurs le php.ini. Logique.

Pas de chance, mon phpinfo dit :
register_globals	Off	Off !!!

C'est sans doute plus une question PHP qu'AlternC, mais si qq'1 par la 
pouvait m'expliquer pourquoi php fait le contraire de ce que php.ini 
demande....


_______________________________________________
Users mailing list
Users at alternc.org
http://alternc.org/cgi-bin/mailman/listinfo/users


Plus d'informations sur la liste de diffusion Users