[AlternC-Users] probleme installation mysql

Retour à l'archive de la liste
Le site d'AlternC
Google Custom Search

Franck Gallos franckgallos at free.fr
Mer 1 Sep 11:36:08 CEST 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Olivier Huet - ASCIST APOGEA wrote:
| Coincidence ? J'ai moi aussi des problème avec le dernier packet
d'AlternC
| mais sur une simple Woody cette fois...
|
| De mon coté, l'install se passe sans soucis (sauf qu'effectivement les
écrans
| debconf ne servent a rien et qu'il faut aller remodifier le
alternc.conf à la
| main puis lancer alternc.install)
|
| Le compte root est bien créé.
| A ce propos, quand on modifie un compte il est toujours à "désactivé" par
| défaut. Certes maintenant si on le passe à activé ca marche ;)

Euh penses-tu que le compte root est désactivé par défaut ??
Mon problème ressemble à register_globals à off, alors que dans mon
php.ini il est bien à on.


| Bref, tout semble bien aller jusqu'a un moment ou j'obtient sur mon
navigateur
| :
|
| Warning: Can't connect to local MySQL server through socket
| '/var/run/mysqld/mysqld.sock' (111) in
| /var/alternc/bureau/class/db_mysql.php on line 73
| Database error: pconnect(localhost, sysusr, $Password) failed.
| MySQL Error: ()
| Session halted.
|
|
| Pourtant, aucun problème avec mysql en ligne de commande... le mot de
passe
| est bien reconnu...

Oui j'ai eu le même problème avec ma Sarge, c'est d'ailleurs pourquoi
mon titre faisait référence explicitement à Mysql, je ne sais pas ce
qu'il s'est passé: j'ai essayé de bidouiller avec my.cnf, avec le lien
symbolique du fichier .sock etc et à grand coup de apt-get --pure remove
et pof sans que j'y comprenne quoi que ce soit j'ai n'ai plus eu ce
problème.
Ensuite est survenu un prob de fonction non reconnu mysql_pconnect, même
traitement au bout de plusieurs résinstall plus de souci. Maintenant
j'ai toujours à la fin de alternc.install et d'ailleurs présent quand je
tente de me logger sur le bureau:

erreur : err_err_1<br>

je ne peux toujours pas me logger et les drapeaux ne fonctionnent pas :-/
Pourtant j'ai accès à la base sans souci et phpmyadmin tourne à merveille.

ps: j'ai songé à faire des test dans la table db ( c'ets bien la table
des users ?) histoire de voir ce qu'il se passe avec l'utilisateur root.
Pas moyen de la lister, les privilèges ne sont même pas accorder en
lecture sur cette table et quelques autres au super-utilisateur. Pouruqoi ?



- --

~  Franck  Gallos
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFBNZgIsXiWewUATLsRArPYAJ4znzzPrVohjs03PAGhCa6ChhOdpwCgj7Zg
uCieyYs804pvz9ibBundBOI=
=1GTi
-----END PGP SIGNATURE-----


Plus d'informations sur la liste de diffusion Users